Why do I have to use the latest Safari or Chrome to create books and not Microsoft Internet Explorer or Firefox?

We are using the latest HTML5 technologies for animations and media. For a long time, only Safari and Chrome fully supported these features.

While Firefox and the latest version of IE now support these features, we have not yet added support for them, so we encourage you to use only Safari or Chrome at present.